初入树莓派5----Docker

  • 树莓派安装 Docker Docker-compose

  • 资料来源:

    http://beekc.top/2019/08/20/raspberry-wifi-ap/

  • 更新

    1
    19.01.07 初始化

导语

  • 3B有 1g 的内存,跑 Raspbian Buster Lite 只占用了不到 100M ,着实浪费.
  • 无聊安上 docker 虽然只有armv7 的镜像可用.
  • 吐槽: 树莓派3以后就算64位了,现在 Raspbian Buster 还是没有64位. kali 都放出64位镜像了.

安装

  • 为了方便直接上官方的一键脚本.不用担心,网络已解决情况下非常好用.

    1
    curl -sSL http://get.docker.com | sh
  • 把对排港博客认用户加入 docker 用户组(对排港博客认为 pi )

    1
    sudo usermod -aG docker pi
  • 开机自启

    1
    2
    sudo systemctl enable docker
    sudo systemctl start docker
  • Docker hello world,自动下载arm32v7镜像

    1
    docker run hello-world
  • 没想到 docker-compose 是最折腾的.

    • linux笔记—docker入门 中提到了树莓派安装 docker-compose 最好通过 pip 安装.

    • 因为 python2 与 python3 的不兼容,有 pip 和 pip3 之分,在 python2 对应的 pip 上折腾许久,依旧无法正常使用,另外 python2 的支持周期最近已经到了,直接切换到 pip3 一次性成功.😂.

    • 安装依赖

      1
      sudo apt-get install libffi-dev libssl-dev
    • 安装 pip3 (Raspbian Buster带有 python 和 python3 没有 python3 的要另外安装 python3)

      1
      sudo apt-get install -y python3-pip
    • 安装 docker-compose

      1
      sudo pip3 install docker-compose
    • 测试

      1
      2
      3
      4
      5
      pi@raspberrypi:~ $ docker-compose version
      docker-compose version 1.25.0, build b42d419
      docker-py version: 4.1.0
      CPython version: 3.7.3
      OpenSSL version: OpenSSL 1.1.1d 10 Sep 2019

结语

  • python2 的支持周期已经结束,尽快切换到 python3 吧.